niklassn
15.05.2021 20:27

Решить в паскале (без массива) №1 составьте не менее трёх вариантов программы определения наименьшего их трех данных чисел. №2 составить программу сортировки по возрастанию значений трёх переменных : а,в,с . №3 заданы размеры а,в прямоугольного отверстия x,y,z кирпича. определить пройдет ли кирпич через отверстие .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
NeSharitVMatematike
13.06.2020 07:53

Первые два вчера

 

В третьем не уверен в самом алгоритме...

 

var

  a, b, x, y, z : real;

begin

  read (a, b, c, x, y);

  if ((a <= x) and (b <= y)) or ((a <= y) and (b <= x))

  or ((a <= x) and (b <= z)) or ((a <= z) and (b <= x))

  or ((a <= z) and (b <= y)) or ((a <= y) and (b <= z)) then writeln ('YES') else writeln ('NO');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота