Bratok16
02.03.2020 11:15

6. составить алгоритм и написать программу вычисления суммы и среднего значения только отрицательных чисел из вводимых n произвольных (как положительных, так и отрицательных) целых чисел.n не больше 10

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ель18
04.10.2020 06:48
Var a:array[1..100] of integer;
i,n,s,k:integer;
begin 
s:=0; k:=0;
write('Введите кол-во чисел: '); readln(n);
write('Введите числа: '); 
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if a[i]<0 then begin
s:=s+a[i];
inc(k);
end;
if k<>0 then 
begin writeln('Ср.знач. отрицательных чисел: ',s/k);
writeln('Сумма отрицательных чисел: ',s); end 
else writeln('Отрицательных членов нет');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота