wormer221
12.05.2020 05:08

с информатикой в Python 9 клас. Урок № 56
Практична робота №16.
«Довжина списку. Зміна, видалення та знаходження заданих елементів списку.»
Увага! Під час роботи з комп’ютером дотримуйтеся правил безпеки та санітарно-гігієнічних норм.

Задання 1. Дано перелік підручників для 9 класу з різних предметів. Розробіть програму створення списку, елементами якого є назви підручників для 9 класу з різних предметів. Визначте загальну кількість підручників; чи є у переліку підручники з інформатики і фізики; номер позиції підручника з хімії.

Задання 2. Створіть програму для обчислення кількості парних елементів у списку, заповненого випадковими числами.
Завдання 3. Створити проект, у якому зі списку чисел потрібно видалити елементи, значення яких більше 35 і менше 65. При цьому числа, що видаляються зберегти в іншому списку. Список заповнити випадковими числами.

Завдання 4. У списку [4, 6, 13, 9, 5, 16, 11] знайти числа, більші 6, збільшити їх удвічі, вивести на екран їх кількість. ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mantsigina
26.05.2022 12:18

Объяснение:

Кажется, еще совсем недавно наступил новый 2013 год. А знали ли Вы забавный факт о том, что 2013 год является первым годом после далекого 1987 года, в котором все цифры различны?

Теперь же Вам предлагается решить следующую задачу: задан номер года, найдите наименьший номер года, который строго больше заданного и в котором все цифры различны.

Входные данные

В единственной строке задано целое число y (1000 ≤ y ≤ 9000) — номер года.

Выходные данные

Выведите единственное целое число — минимальный номер года, который строго больше y, в котором все цифры различны. Гарантируется, что ответ существует.

Примеры

входные данные

1987

выходные данны

2013

входные данные

2013

выходные данные

2014

0,0(0 оценок)
Ответ:
nusuperirish
13.10.2021 13:44

#include <iostream>

using namespace std;

int main()

{

   const int N = 5;

   const int M = 3;

   int matrix[N][M];

   for(int i = 0; i < N; i++)

   {

       for(int j = 0; j < M; j++)

       {

           matrix[i][j] = rand() % 10;

           cout << matrix[i][j] << "\t";

       }

       cout << endl;

   }

   int min = matrix[0][1];

   for(int i = 0; i < N; i++)

   {

       for(int j = 0; j < M; j++)

           if((j + 1) % 2 == 0)

           {

               if(matrix[i][j] < min)

                   min = matrix[i][j];

           }

   }

   cout << "\n" << min;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота