artemgavrev
07.07.2022 05:20

Написать программу в pascal. из предложения вывести слова с заданным количеством слогов.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
красотка368
24.07.2020 17:53
Количество слогов считаем по количеству гласных букв в слове.

Program pr;
uses crt;

var str,s: string; 
a,i,j,len,k,kslog: byte;      

Begin 
Writeln('Введите предложение'); 
readln(str);   
Writeln('Введите кол-во слогов'); 
readln(k);   
Writeln('Слова с ',k,' слогами:'); 
Writeln;   

len:=length(str); 
a:=0; 
kslog:=0; 

for i:=1 to len do     
            Begin           
                   if (str[i] = ' ')   then         
                        Begin         
                           s:=copy(str,i+1,a);                   
                 
                           for j:=1 to length(s) do           
                           Begin             
                           if s[j] in ['А','О','У','Э','Ы','Я','Ё','Ю','Е','И','а','о','у','э','ы','я','ё','ю','е','и'] then                                                    inc(kslog);           
                           end;                           
                   if (k=kslog) then Writeln(s);               
                   kslog:=0;               
                   a:=0;         
                      end         
                   else  a:=a+1;     
             end;           

Writeln;     
Writeln('Для завершения программы нажмите Enter');     
readln;      
end.      
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота