hmg28409
27.01.2023 02:26

Написать программу, которая будет распечатывать все числа в промежутке от 20 до 150, которые делятся на число 5.Написать программу, которая

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ання2018
01.05.2023 13:28
// Напишите программу, которая в последовательности натуральных чисел определяет количество
//чисел, кратных 3. Программа получает на вход количество чисел в
//последовательности, а затем сами числа. В последовательности всегда имеется число,
//кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300.
//Программа должна вывести одно число - количество чисел, кратных 3.

Var  i,j,x  :word;
     n      :integer;
begin
  writeln('Введите количество цифр в последовательности');
  Readln (j);
  if j>100 then //Проверка накличество чисел в последовательности
      begin
        writeln ('По условия задачи цифр не должно быть более 100');
        writeln ('Введите количесво цифр еще раз');
        readln (j);
      end;
  for i:=1 to j do
  begin
    Writeln ('Введите ',i,' число');
    readln (n);
    if n>300 then //проверка максимального значения числа
      begin
        writeln ('Данное число не удовлетворяет условиям задачи (>300');
        writeln ('Введите его еще раз');
        readln (n);
      end;
      n:= n mod 3;
      if n=0 then x:=x+1;
      end;
   Writeln ('Количество чисел, кратных 3:');
   Writeln (x);
end.
0,0(0 оценок)
Ответ:
Мистер9900
01.05.2023 13:28
// Напишите программу, которая в последовательности натуральных чисел определяет количество
//чисел, кратных 3. Программа получает на вход количество чисел в
//последовательности, а затем сами числа. В последовательности всегда имеется число,
//кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300.
//Программа должна вывести одно число - количество чисел, кратных 3.

Var  i,j,x  :word;
     n      :integer;
begin
  writeln('Введите количество цифр в последовательности');
  Readln (j);
  if j>100 then //Проверка накличество чисел в последовательности
      begin
        writeln ('По условия задачи цифр не должно быть более 100');
        writeln ('Введите количесво цифр еще раз');
        readln (j);
      end;
  for i:=1 to j do
  begin
    Writeln ('Введите ',i,' число');
    readln (n);
    if n>300 then //проверка максимального значения числа
      begin
        writeln ('Данное число не удовлетворяет условиям задачи (>300');
        writeln ('Введите его еще раз');
        readln (n);
      end;
      n:= n mod 3;
      if n=0 then x:=x+1;
      end;
   Writeln ('Количество чисел, кратных 3:');
   Writeln (x);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота