solovyovaolena
22.02.2021 00:15

Информатика Составить программу в паскаль ABC самостоятельно: Ввести возраст человека (от 1 до 100 лет) и вывести его вместе с
последующим словом «год», «года» или «лет».
Примеры:
Введите возраст: Введите возраст:
24 57
Вам 24 года Вам 57 лет

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
KasiaW
11.11.2022 08:33
//Pascal ABC.NET v3.0 сборка 1111

Const
 s=5;

Var
 ar:array[1..s] of integer;
 n,m,i:integer;
begin
 writeln('N');
 readln(n);
 writeln('M');
 readln(m);
 writeln('Array:');
 for i:=1 to s do
   readln(ar[i]);
 writeln('First array:');
 for i:=1 to s do
  begin
   write(ar[i]:4);
   if ar[i] div n<>0 then ar[i]:=ar[i]+m;
  end;
 writeln;
 writeln('Final array:');
  for i:=1 to s do
   write(ar[i]:4);
end. 

Пример ввода:
3
3
1
2
3
4
5
Пример вывода:
First array:
   1   2   3   4   5
Final array:
   1   2   6   7   8

//Блок-схема во вложении
Ввести двумерный массив a. все элементы, которые при целочисленном делении на n ненулевое значение,
0,0(0 оценок)
Ответ:
dis8
17.11.2022 01:57
//Pascal ABC.NET v3.0 сборка 1111

Const
 n=5;

Var
 ma:array[1..n,1..n] of integer;
 i,j:integer;
begin
 writeln('Matrix reading...');
 for i:=1 to n do
  begin
   writeln;
    for j:=1 to n do
      readln(ma[i,j]);
  end;
 writeln('First matrix:');
 for i:=1 to n do
  begin
   writeln;
    for j:=1 to n do
     begin
      write(ma[i,j]:4);
      if (ma[i,j]<-8) or (ma[i,j]>6) then ma[i,j]:=sqr(ma[i,j]);
     end;
  end;
 writeln;
 writeln('Final matrix:');
 for i:=1 to n do
  begin
   writeln;
    for j:=1 to n do
     write(ma[i,j]:4);
  end;
end.

Пример ввода:
1
2
3
4
5

6
7
8
9
1

2
3
4
5
6

7
8
9
1
2

3
4
5
6
7
Пример вывода:
First matrix:
   1   2   3   4   5
   6   7   8   9   1
   2   3   4   5   6
   7   8   9   1   2
   3   4   5   6   7
Final matrix:
   1   2   3   4   5
   6  49  64  81   1
   2   3   4   5   6
  49  64  81   1   2
   3   4   5   6  49
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота