cfvceyu2004
04.03.2020 05:53

написать программу которая принимает на вход набор чисел, составляет из них список вычисляет среднее арифметическое равное 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
wolfe8
04.08.2021 02:21

Program Markovsp1;
uses crt;
const
  eps=0.001;
var
  t,s:real;
  i:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Программа вычисляет частичную сумму ряда ');
  writeln('  S=1+1/(2^2)+1/(3^2)+1/(4^2)+... ');
  writeln('Вычисление прекратится, когда модуль очередного слагаемого станет меньше 0,001');
используется цикл repeat');
  writeln();
  s:=0;
  i:=1;
  repeat
    t:=1/((i)*(i));
    s:=s+t;
    //writeln('i=',i,'  T=',t:0:6,'  S=',s:0:6);
    i:=i+1;
  until abs(t)<eps;
  writeln('s=',s:0:6,' (pi^2)/6=',(pi*pi)/6:0:6);
  writeln('Приближение к (pi^2)/6 равно ',s-(pi*pi)/6:0:6);
end.

Program Markovsp2;
uses crt;
const
  eps=0.001;
var
  t,s:real;
  i:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Программа вычисляет частичную сумму ряда ');
  writeln('  S=1+1/(2^2)+1/(3^2)+1/(4^2)+... ');
  writeln('Вычисление прекратится, когда модуль очередного слагаемого станет меньше 0,001');
используется цикл while');
  writeln();
  s:=0;
  i:=1;
  t:=1;
  while t>eps do
    begin
      t:=1/(i*i);
      s:=s+t;
      //writeln('i=',i,'  T=',t:0:6,'  S=',s:0:6);
      i:=i+1;
     end;
  writeln('s=',s:0:6,' (pi^2)/6=',(pi*pi)/6:0:6);
  writeln('Приближение к (pi^2)/6 равно ',s-(pi*pi)/6:0:6);
end.

0,0(0 оценок)
Ответ:
pepka1
09.08.2020 12:50
Паскаль АВС:

Program  Albinur;
uses crt;
var
  v0,a,t : real;
begin
  writeln('Программа вычисляет скорость объекта при равноускоренном движении');
  writeln(' в заданный момент времени');
  write('Введите начальную скорость в м/с  '); readln(v0);
  write('Введите ускорение в м/с^2  '); readln(a);
  write('Введите время в с  '); readln(t);
  writeln();  writeln();
  writeln('*** Вычисляю... ***');
  writeln();  writeln();
  writeln('Через ',t,' секунд после начала движения скорость объекта будет равна ',v0+a*t,' м/с');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота