ZheniaBabich
11.02.2020 13:40

Написать программу, которая определяет является ли целое n, заданное пользователем числом Мерсенна. 4 ≤ n ≤ 2 000 000 000.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Bomb9931
14.02.2021 16:05

1. а) 5>3!

  б) a>b!

  в) (5)<(8)

2. a) print (b, "+", a, "=?")

   б) print ("(",a,")(",b,")")

   в) print ("a=",a,"b=",b)

   г) print ("ответ: (",a,",",b,")")

3. а) 7/3

   б) 14

   в) 9

   г) 2

4. а) 8

   б) 30

   в) 0

 г) 32

5. Program Z1;

Var a, b, c, Summ, Umn, Sr: real;

Begin

Read (a);

Read (b);

Read (c);

Summ:=a+b+c;

Writeln ('Сумма чисел: ', Summ);

Umn:=a*b*c;

Writeln ('Произведение чисел: ', Umn);

Sr:=Summ/3;

Writeln ('Среднее арифметическое чисел: ', Sr:2:6);

End.

Объяснение:

1. Здесь просто вывод прописываешь. Вместо а подставляешь 5, вместо b 3. То что в кавычках, программа считывает как печатный символ и пропечатывает.

2. Аналогично первому но обратная операция, Print ( ) - команда вывода информации. В кавычки берем то что хотим напечатать, вместо напечатанных цифр у нас есть переменные a и b

3. Тут по порядку просто вычисляем значение переменной c, вместо а подставляем 5, вместо b - 3. Привила математики: сначала вычисляем то что в скобках, потом деление и умножение, а затем уже сложение и вычитание.

4. Аналогично третьему заданию. Только здесь % - это остаток от деления, а // - это целая часть от деления.

0,0(0 оценок)
Ответ:
МастерФейк
11.05.2023 16:04

Опера «Риголетто» написана по мотивам пьесы В. Гюго «Король забавляется». В основе драмы были реальные действующие герои, только перенесенные в оригинальные сюжетные коллизии. После первой же премьеры пьеса была строго запрещена цензурой, как подрывающая авторитет короля. Лишь после падения режима Наполеона III, через 50 лет после первой постановки, драма вновь предстала перед публикой. В России в те времена постановок и вовсе не было, по этическим соображениям. Эта опера показывает истинную и чистую любовь, которая вынуждает молодую девушку пожертвовать собой ради любимого. Кроме того в ней есть измены, предательство, наемный убийца, мистика и глубокая боль отца, потерявшего свою единственную дочь, но вынужденного оставаться в своей маске шута.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота