195920
24.07.2020 02:42

Написать программу которая вычисляет сумму диагональных элементов квадратной матрицы

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
АлфавитABC
07.10.2020 19:09
//Листинг программы и скриншот работы - в приложениях.
//Написано на PascalABC.NET но будет работать в простом Паскале

const
    max = 12;
var N,i,j:byte;
    sum:integer;
    ar:array[1..max, 1..max] of integer;

begin
  writeln('Вычислить сумму диагональных элементов квадратной матрицы');
  write('Введите размер матрицы N = ');
  readln(N);
 
  for i:=1 to N do begin
    for j:=1 to N do begin
      ar[i,j]:=random(-12,12);//любые числа
      write(ar[i,j]:6);
    end;
    writeln();
  end;
 
  sum:=0;
  for i:=1 to n do
    for j:=1 to n do
      if ( i = (n-j+1) ) or ( i = j ) then
        sum:=sum+ar[i,j];

  writeln('Сумма sum = ', sum);
end.

Написать программу которая вычисляет сумму диагональных элементов квадратной матрицы
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота