ilyailushin
24.05.2021 16:25

Напишите программу на языке c++, которая определяет, будет ли k-й день выходным, если 1 января - понедельник. требуется вывести "yes", если этот день выходной, "no" если нет.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
elizavetamilas
15.05.2020 11:16
Var - список переменных
переменные а,с присваивают тип integer, т.е. целые числа; b присваивает тип string, т.е строковый тип
begin - начало программы
readln - оператор ввода, окончание ln осуществляет переход на новую строку
str(a,b) - т.е. преобразовать данные числа в строку
переменная b так же присваивает тип строковый
Val(b,a,c) где: b- строка, а-результат, с-позиция с которой произошла ошибка преобразования или 0
writeln(а) - оператор вывода, окончание ln осуществляет переход на новую строку
end. - конец программы
0,0(0 оценок)
Ответ:
siemens227
19.11.2022 11:08
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Кол-во элементов:');
  var a:=ArrRandomReal(n,-10,20); a.Println;
  Writeln('С округлением если |x|<1');
  for var i:=0 to n-1 do
    if abs(a[i])<1 then a[i]:=Round(a[i]);
  a.Println
end.

Тестовое решение:
Кол-во элементов: 10
-0.751956142835299 5.95022566427953 3.58861613254464 7.42331713783709 -4.75036238075717 -9.41228387384316 -0.700975591643235 3.85500546258642 -1.94321916994789 19.3021338336645
С округлением если |x|<1
-1 5.95022566427953 3.58861613254464 7.42331713783709 -4.75036238075717 -9.41228387384316 -1 3.85500546258642 -1.94321916994789 19.3021338336645
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота