snigireva00
25.03.2020 17:47

C++ Для двух натуральных чисел P и Q, меньших 1000000, напишите программу, которая определяет, числа являются взаемнопростимы (не имеют общих делителей, кроме 1). Код решения уже есть
#include iostream
using namespace std;
int func(int &P,int &Q){
while (P > 0 && Q > 0 && P != Q)
{
if (P > Q) {
P = P - Q;
}
else
Q = Q - P;
}
if (P == 1 && Q == 1)
cout "vsaemoprosti";
else
cout "ne vsaemoprosti";
return 0;
}
int main()
{
int P, Q;
cout > P;
cout > Q;
func(P, Q);
}
НУЖНО ЗДЕЛАТЬ С УКАЗАТЕЛЯМИ!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MilankaMarkova
01.07.2022 10:10

var  

  arr:array[1..1000] of integer;

  i,N:integer;

  max:integer;

begin

   max:=1;

   

   write('Укажите кол-во эл-ов - ');

   

   read(N);

   

   for i:=1 to N do//Присваивание и вывод массива

   begin

       arr[i]:=1+random(100);

       

       write(arr[i],'  ');

       

       if arr[i]>max then max:=arr[i];

   end;

   

   writeln;

   

   writeln('Максимальный эл-т - ',max);

   

   for i:=1 to N do//Увеличение чет. эл-ов

     begin

     if arr[i] mod 2=0 then arr[i]:=arr[i]+max;

     

     write(arr[i],'  ');

     end;

 

end.

Объяснение:

0,0(0 оценок)
Ответ:
катяшакотик
26.01.2020 05:15

11211

Объяснение:

число 82 = 80 + 2 (состоит из 8 десятков и 2 единиц)

числа 6 (состоит из 6 единиц)

команда 1 увеличивает число на 1 единицу

команда 1 переводит число в новый разряд (из единиц команда получает десятки, из десятков команда получает сотни и т.д.)

следователь самый короткий путь это привести число 6 к количеству десятков в числе 82 (командой 1), затем привести полученное число в новый разряд (командой 2),потом привести полученное число к числу 82 (командой 1)

6 + 1 = 7     (команда 1)

7 + 1 = 8     (команда 1)

8 * 10 = 80     (команда 2)

80 + 1 = 81     (команда 1)

81 + 1 = 82     (команда 1)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота