alinabiychinska
27.12.2022 19:12

Составьте программу, которая имитирует работу калькулятора.
работе делается в visual studio.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Aleksandr31821
19.02.2020 20:00

var

 n, max, count, contrl, max2: integer;

begin

 contrl := 0;

 max := 0;

 Writeln('Введите числа: ');

 Readln(n);

 while n <> 0 do

 begin

   Inc(count);

   if n>max then begin max2:=max; max:=n end

   else if n > max2 then max2 := n;

   Read(n);

 end;

 max2*=max;

 Writeln('Введите контрольное значение: ');

 Read(contrl);

 Writeln('Получено: ', count, ' чисел');

 Writeln('Получено контрольное значение: ', contrl);

 Writeln('Вычисленное контрольное значение:: ', max2);

 if contrl = max then Writeln('Контроль пройден')

 else Writeln('Контроль не пройден');

end.

0,0(0 оценок)
Ответ:
Вишня007
19.02.2020 20:00

var

 n, max, count, contrl: integer;

begin

 contrl := 0;

 max := 0;

 Writeln('Введите числа: ');

 Readln(n);

 while n <> 0 do  

 begin

   Inc(count);

   if (n mod 10 = 0) and (n > max) then max := n;

   Read(n);

 end;

 Writeln('Введите контрольное значение: ');

 Read(contrl);

 Writeln('Получено: ', count, ' чисел');

 Writeln('Получено контрольное значение: ', contrl);

 Writeln('Вичисленное контрольное значение:: ', max);

 if contrl = max then Writeln('Контроль пройден')  

 else Writeln('Контроль не пройден');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота