viktoria168
21.04.2021 15:10

Как на pascal abc написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры? количество цифр в числе не известно! число целочисленное! желательно с объяснениями ( вне программы ). заранее !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ilyamaximov514
20.09.2020 09:16
Var a,b,c,d:integer;
begin
writeln('введите число'); //запрос числа
readln(a);
d:=a;                 //это для красоты
while (a<>0) do begin //пока мы не дойдём до последней цифры в числе делать следующее
  b:=a mod 10;        //берём последнюю цифру числа 
  c:=c+b;             //находим сумму цифр
  a:=a div 10;        //убираем из данного числа последнюю цифру
  end;
 writeln('сумма цифр числа ',d,' = ',c); // вывод результата
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота