asylkhanova05
21.04.2021 15:10

Как на pascal abc написать программу, которая будет считать сумму цифр числа, введенного с клавиатуры? количество цифр в числе неизвестно! число целое. желательно с объяснениями (вне программы). заранее ! p.s. я 15 ! !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Пеперони228
30.08.2020 17:13
Program LOL2016;
var n,s,r:integer;
begin
readln(n);
s:=0;
while(n <> 0) do begin
r:=n mod 10;
s:=s+r;
n:=n div 10;
end;
writeln(s);
end.

если что то не понятно просто спроси и я обьясню  :)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота