cefevupi
06.02.2021 19:52

Pascalabc.net текстовый файл input.txt содержит натуральные числа. написать программу, которая создает текстовый файл output.txt, содержащий все четные числа файла input.txt в порядке возрастания.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Виктор338
09.10.2020 02:59

Попробуй этот код

uses crt;

var f,g:text;

   a,max,min:integer;

begin

assign(f,'C:\in.txt');

assign(g,'C:\out.txt');

reset(f);

rewrite(g);

max:=0;

min:=0;

reset(f);

while not eof(f) do

     begin

     read(f,a);

     if a>max then max:=a;

     if a<min then min:=a;

     end;

writeln(g,'max ',max);

writeln(g,'min ',min);

close(f);

close(g);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота