alina1934
06.01.2023 16:50

Написать программу решения следующей : определить периметры трѐх треугольников, если заданы координаты их вершин. использовать подпрограмму-функцию

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Воряк
01.05.2020 17:44
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 uses crt; var i,xa,ya,xb,yb,xc,yc: integer;   function Dlina(x1,y1,x2,y2: integer):real; var d: real; begin d:= sqrt(sqr(y1-y2)+sqr(x1-x2)); Dlina:=d; end;   function Perimetr(a,b,c: real): real; begin Perimetr:=a+b+c; end;   procedure Vvod (nt: byte; var ax,ay,bx,by,cx,cy: integer); begin writeln ('Координаты вершины A ',nt,' треугольника'); readln (ax,ay); writeln ('Координаты вершины B ',nt,' треугольника'); readln (bx,by); writeln ('Координаты вершины C ',nt,' треугольника'); readln (cx,cy); end;   begin for i:=1 to 3 do     begin     Vvod (i,xa,ya,xb,yb,xc,yc);     writeln ('Периметр ',i,' треугольника = ',Perimetr(Dlina(xa,ya,xb,yb),Dlina(xb,yb,xc,yc),Dlina(xc,yc,xa,ya)):0:2);     writeln;     end; readkey end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота