nazarpetrenko1
29.06.2022 23:06

Решить в питоне (python) всего 1 15 !
надо написать программу, которая принимает текст и выводит два слова: наиболее часто встречающееся и самое длинное. без import.

если ответите.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dima012002
10.10.2020 10:28

n = input()

n=n.replace("."," ")

n=n.replace(","," ")

n=n.replace("!"," ")

n=n.replace("?"," ")

n=n.replace("-"," ")

n=n.replace("("," ")

n=n.replace(")"," ")

n = n.split()

maxlength = ""

maxcount  = ""

for a in range(len(n)):

   if len(n[a])>len(maxlength):

       maxlength = n[a]

   if n.count(n[a])>len(maxcount):

       maxcount = n[a]

 

print("maxcount: "+maxcount)

print("maxlength: "+maxlength)

Объяснение:

str.replace(old,new) = заменяет old_word на new_word (чтобы очищать от . , ! ? ( ) -символов(ещё есть другие но эти основные(можешь просто копировать вставить заменить на другие))

str.split() = разделяет строку по пробелам

array.count()=считает количество строк в данном массиве

len(array) = дает длину массива

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота