ramil161
30.03.2020 17:22

Напишите программу, которая считает количество предложений во введенной строке и выводит его. предложение может заканчиваться на: . (точка) ; (точка с запятой) ? (вопросительный знак)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
школааксай
08.10.2020 12:09
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (s,k):=(ReadlnString,0);
  for var i:=1 to s.Length do
    if s[i] in ['.',';','?'] then k+=1;
  Writeln('Количество предложений равно ',k)  
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота