Arina3010
29.06.2022 02:45

нужно написать программу, которая с функции, выводит наибольшую цифру в введенном числе.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
amaliyaazlzova
08.10.2020 00:06
Var a:integer;
function max(n:integer):integer;
var m:integer;
begin
n:=abs(n);
m:=0;
while n<>0 do
 begin
 if n mod 10 > m then m:=n mod 10;
 n:=n div 10;
 end;
max:=m;
end;
begin
write('a = ');
readln(a);
writeln('Максимальная цифра = ',max(a));
end.

Пример:
a = -185
Максимальная цифра = 8
0,0(0 оценок)
Ответ:
diduh2002
08.10.2020 00:06
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

function MaxDigit(n:int64):integer;
begin
  Result:=0;
  n:=Abs(n);
  while n>0 do (Result,n):=(Max(Result,n mod 10),n div 10)
end;

begin
  var n:int64;
  Write('Введите число: '); Read(n);
  Writeln('Максимальная цифра равна ',MaxDigit(n))
end.

Пример
Введите число: 340458239345
Максимальная цифра равна 9
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота