deniwolf200
05.04.2023 20:11

Написать программу на языке Java (задание №5)


Написать программу на языке Java (задание №5)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
1232964
09.04.2022 05:45
//Pascal ABC.NET 3.1 сборка 1219

uses
 system,system.Windows.Forms;

Var
 dat:DateTime;
 myForm:Form;
 myButton:Button;
 myTextBox:TextBox;

 procedure MyButtonClick(sender:Object;e:EventArgs);
  begin {при каждом нажатии на кнопку значение dat обновляется и выводится в текстовое поле}
 dat:=datetime.Now;
 myTextBox.Text:=dat.ToString;
 end;
 begin
  myForm:=new Form; //создание объекта - формы
   myform.Left:=500;
   myform.top:=500;
   myform.AutoSize:=true;
   myform.Width:=300;
   myform.Height:=100;
  myTextBox:=new TextBox; //создание объекта - текстового поля
  myTextBox.Left:=80;
   myTextBox.Top:=40;
   myTextBox.Enabled:=true;
   myTextBox.Width:=105;
   myTextBox.Height:=100;
   myTextBox.MaxLength:=16;
   myTextBox.ReadOnly:=false;
   myTextBox.Visible:=true;
  myButton:=new Button; //создание объекта - кнопки
   myButton.Text:='Now';
   myButton.Left:=80;
   myButton.top:=80;
   myButton.AutoSize:=true;
   myForm.Controls.Add(myButton); //вешаем на форму кнопку и поле
   myForm.Controls.Add(myTextBox);
   myButton.click+=MyButtonClick; //присваиваем событие при нажатии на кнопку
   Application.Run(myForm);
end.
0,0(0 оценок)
Ответ:
vlad016263624524677
16.11.2020 03:50
//Pascal ABC.NET 3.1 сборка 1219

Type
 ty=array[1..60] of integer;

Var
 a,b,c:array[1..20] of integer;
 ar:ty;
 n,m,k,i:integer;

procedure quicksort(var a:ty; Lo,Hi: integer);

procedure sort(l,r: integer);
var
i,j,x,y: integer;
begin
i:=l;
 j:=r;
 x:=a[random(r-l+1)+l];
repeat
while a[i]<x do
 i:=i+1;
 while x<a[j] do
 j:=j-1;
  if i<=j then
   begin
    if a[i] > a[j] then
     begin
      y:=a[i];
 a[i]:=a[j];
 a[j]:=y;
     end;
    i:=i+1;
 j:=j-1;
  end;
    until i>=j;
  if l<j then sort(l,j);
  if i<r then sort(i,r);
end;

begin;
  randomize;
  sort(Lo,Hi);
end;

 begin
 readln(n);
 for i:=1 to n do
 begin
  readln(a[i]);
  ar[i]:=a[i];
 end;
 readln(m);
 for i:=1 to m do
 begin
  readln(b[i]);
  ar[i+n]:=b[i];
 end;
 readln(k);
 for i:=1 to k do
 begin
  readln(c[i]);
  ar[i+n+m]:=c[i];
 end;
 quicksort(ar,1,n+m+k);
 writeln('Final array:');
 for i:=1 to n+m+k do
 write(ar[i]:4);
end.

Пример ввода:
3
1
2
3
3
1
2
3
3
1
2
3
Пример вывода:
Final array:
   1   1   1   2   2   2   3   3   3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота