Войти
Регистрация
Спроси ai-bota
dangah31
06.05.2022 09:58
Составьте программу которая выводит на экран из всех трёхзначных чисел, только те у которых квадрат первой цифры равен сумме двух остальных.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Эплик1
24.05.2020 17:20
ВЫПОЛНИТЕ В ПРОГРАММЕ КУМИР ...
данил2908
25.07.2020 02:30
Привести словесное описание алгоритма решения задачи и составить блок-схему: x=8 y=4x3-4x-1...
Minenub
20.03.2020 02:13
1) Построить таблицу истинности._а) (А или В) и B_б) A или (В и С)2) Найти значение выражения (1 или 0) и (1 и 1) или (0 и 0)3) придумать собственное имя, удовлетворяющему...
Sasha0067890
24.09.2020 19:33
По поражаемым объектам компьютерные вирусы делятся на: – файловые вирусы, – загрузочные вирусы, – сценарные вирусы, – макровирусы, вирусы, – поражающие исходный код....
Бекки5
26.08.2022 23:56
1) Построить таблицу истинности. _а) (А или В) и B _б) A или (В и С)2) Найти значение выражения (1 или 0) и (1 и 1) или (0 и 0)3) придумать собственное имя, удовлетворяющему...
smashsmash83p08jrb
24.05.2023 15:47
Напишите программу, которая переводит переданное ей неотрицательное целое число в четырёхзначный шестнадцатеричный код, сохранив лидирующие нули. используйте процедуру....
antuarmenskaya
20.10.2021 03:10
2. с клавиатуры вводится трёхзначное число. вывести на экран двузначное число, состоящее из первой и последней цифры введенного числа. пример: ввели число 672. выводим...
TolstoyLev
20.10.2021 03:10
После выполнения фрагмента программы : m: =0; for i: =1 to 10 do begin if i mod 3=0 then a[i]: =2*(i-1) else a [ i ]: =-1; m : = a [ i ]+ m ; end ; переменная m принимает...
MrThomasFeed
20.10.2021 03:10
Пользователь вводит цену за один кг конфет. постройте блок-схему алгоритма, который выводит цену за: 1.1, 1.2, … ,2,9 кг конфет....
Dasha2k18
20.10.2021 03:10
Вычисли количество адресуемых ячеек памяти, если разрядность шины адреса равна 32: n=...
Ответ:
nikoscki
03.10.2020 07:49
Var
i: integer;
begin
for i:=100 to 999 do
if (sqr(i div 100) = i mod 10 + i div 10 mod 10) then
writeln(i);
end.
0,0
(0 оценок)
Ответ:
Ks1mak
03.10.2020 07:49
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
for var i:=100 to 999 do begin
var d1:=i div 100;
var d2:=(i div 10) mod 10;
var d3:=i mod 10;
if sqr(d1)=d2+d3 then Print(i)
end;
Println
end.
Тестовое решение:
101 110 204 213 222 231 240 309 318 327 336 345 354 363 372 381 390 479 488 497
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота