Милана4455
03.06.2021 07:59

Написать программу на паскале. найти 11 последовательных натуральных чисел, сумма квадратов которых сама является квадратом натурального числа.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ksusha256
07.10.2020 20:07
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var t: real;
var i:=1;
while true do
begin
t:=range(i,i+10).Select(x->x*x).Sum();
if (frac(sqrt(t))=0) then break;
inc(i);
end;
range(i,i+10).Println();
end.
0,0(0 оценок)
Ответ:
лада161
07.10.2020 20:07
Var
  i,n,s:integer;

begin
  n:=1;
  while true do begin
    s:=0;
    for i:=n to n+10 do s:=s+i*i;
    if s=Sqr(Trunc(Sqrt(s))) then break;
    n:=n+1
    end;
  Write('Сумма квадратов чисел на интервале [',n,';',n+10,'] = ');
  Writeln(s,' = ',Trunc(Sqrt(s)),'^2')
end.

Результат
Сумма квадратов чисел на интервале [18;28] = 5929 = 77^2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота