PamPam98
01.04.2023 05:15

Написать программу, которая вычисляет среднюю (за неделю) температуру воздуха. исходные данные должны вводиться во время работы программы. рекомендуемый вид экрана во время работы программы ниже (данные, введенные пользователем, выделены полужирным шрифтом). введите температуру воздуха за неделю. понедельник -> 12 вторник -> 10 ' среда -> 16 четверг -> 18 пятница -> 17 суббота -> 16 воскресенье -> 14 средняя температура за неделю: 14.71 град.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Shedhfjfdhcdgb4573
04.10.2020 15:55
Var
  a: array[1..7] of string = ('Понедельник', 'Вторник', 'Среда', 'Четверг', 'Пятница', 'Суббота', 'Воскресенье');
  av: real; i, t: integer;

begin
  writeln('Введите температуру воздуха за неделю.');
  for i := 1 to 7 do
  begin
    write(a[i], ' -> '); readln(t); av := av + t;
  end;
  av := av / 7;
  writeln('Средняя температура за неделю: ', av:0:2, ' град.');
  readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота