artemonimus
24.10.2022 13:06

Задан одномерный числовой массив.напишите программу которая находит второй по величене после максимльного элемент и его номер . решение паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Август228
07.10.2020 03:47
// PascalABC.NET 3.3, сборка 1562 от 02.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  var s:=a.Distinct.OrderBy(x->x).Reverse.Skip(1);
  if s.Count>0 then begin
    var i:=a.FindIndex(t->t=s.First);
    Writeln('Искомый элемент равен ',a[i],' его порядковый номер ',i+1)
    end
  else Writeln('Нет искомых элементов')
end.

Пример
n= 13
-7 -2 -32 9 21 -31 34 -34 27 -35 11 7 -10
Искомый элемент равен 27 его порядковый номер 9
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота