IcecreamXD
13.10.2021 01:37

Написать программу, паскаль. дано натуральное число n. вычислить s = 1! + 2! +3! + + n! (n> 1)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vasx
07.10.2020 00:17
// PascalABC.NET 3.3, сборка 1549 от 17.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=BigInteger(0);
  var f:=BigInteger(1);
  for var i:=1 to ReadInteger('n=') do begin
    f*=i;
    s+=f
    end;
  Writeln('S= ',s)
end.

Примеры
n= 5
S= 153

n= 20
S= 2561327494111820313

n= 100
S= 94269001683709979260859834124473539872070722613982672442938359305624678223479506023400294093599136466986609124347432647622826870038220556442336528920420940313
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота