анжелаКоТ1
21.09.2020 07:11

1 написать программу удвоения меньшего из двух неравных чисел 2 написать программу увеличить число х на один если оно четное уменьшит на 1 если нечетное

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Фиджиии
12.03.2021 10:45

1.

a, b = 1, 2

if a < b:

a *= 2

else:

b *= 2

2.

x = 43 # Любое число

if x%2 == 0:

x += 1

else:

x -= 1

0,0(0 оценок)
Ответ:
kvm1
12.03.2021 10:45

1)

var a,b:integer;

begin

 writeln('Введите два числа:');

 readln(a,b);

 if a>b then

   b:=b*2

 else begin

 if b>a then

   a:=a*2;

end;

writeln('Первое число =',' ',a);

 writeln('Второе число =',' ',b);

end.

2)

var x:integer;

begin

 writeln('Задайте число:');

 readln(x);

 begin

 if (x mod 2=0) then

  inc(x)

 else

  dec(x);

   end;

writeln(x);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота