SchillerAlice
02.03.2021 08:31

Синформатикой напишите программу, которая запрашивает четырёхзначное число, разрезает его пополам и выводит половинки через пробел. sample input 1: 1234 sample output 1: 12 34 sample input 2: 1200 sample output 2: 12 00 напишите программу, которая запрашивает пятиразрядное число и выводит число, составленное из цифр данного числа взятых задом наперёд. sample input 1: 12345 sample output 1: 54321 sample input 2: 12000 sample output 2: 21

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Serey9999
26.08.2020 15:17
#include <iostream>using namespace std;int main() {  int a, b, c, d;  cin >> a;  b = a/100;  c = a%100;  cout << b << " " << c;  return 0;}
но есть проблема, переменные типа int сокращает 00 до 0
и на выводе получается не 12 00, а 12 0
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота