xayalaamirova2
06.01.2022 03:13

2) напишите программу, вычисляющуюплощадь и периметр прямоугольника. если х=1,то s=a*b; если х=2, то p=2*(a+b); если х=3, то«выход».3) создать и напечатать одномерный массивслучайными числами от 0 до 15 и вывести наэкран те из них, которые больше 10.4) имеются данные об успеваемости 10учащихся. определите средний уровеньуспеваемости. решить с применениямассива.5) чему будут равны переменныеx: =0for i: =-2 to 0 don: =iti; x: =x+n; ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
safeer
06.06.2023 07:48
Информационный вес символа при алфавитном подходе считается, что каждый символ текста имеет определенный информационный вес, информа­ционный вес символа зависит от мощности алфавита. а ка­ким может быть наименьшее число символов в алфавите? оно равно двум! скоро вы узнаете, что такой алфавит ис­пользуется в компьютере. он содержит всего 2 символа, ко­торые обозначаются цифрами «0» и «1». его называют дво­ичным алфавитом. изучая устройство и работу компьютера, вы узнаете, как с всего двух символов можно пред­ставить любую информацию. информационный вес символа двоичного алфавита принят за единицу информации и называется 1 бит.
0,0(0 оценок)
Ответ:
rutasolntseva
15.08.2022 15:18

ответ:

. в нужно вывести все составные числа из промежутка [2; n]. код программы:

program lab3;

var i,n,j,s,l: integer;

m: real;

begin

readln (n);

for i: =2 to n do

begin

s: =trunc (sqrt (i));

for l: =2 to s do

begin

m: = i mod l;

if m=0 then

write (' ',i);

end;

end;

end.

но проблема - как только s становится больше 2, составные числа начинают несколько раз повторятся, т.к., например 12 делится и на 2 и на 3. вопрос: как мне сделать выход из цикла после первого успешного деления?

var

i, n, j, s, l: integer;

m: real;

begin

readln(n);

for i : = 2 to n do

begin

s : = trunc(sqrt(i));

for l : = 2 to s do

begin

m : = i mod l;

if m = 0 then

begin

write(' ', i);

break;

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота