Стерва12345
12.06.2021 22:06

Составить программу, отгадывающую натуральное четное число, загаданное пользователем. ниже представлен рекомендуемый вариант диалога во время работы программы: загадайте натуральное четное число прибавьте к нему 4
уменьшите на 6 поделите на 2 что у вас получилось? вы загадали число

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nosanchuk14
24.05.2020 00:25

и какая вероятность что пользователь не ошибется?)))

 

program i_guess_number;
uses crt;
var changes: array [1..2,1..10] of integer;
i,op,n:integer;
s:string;
res:real;

BEGIN
    randomize;
    writeln("Загадайте число");
    n := 0;
    repeat
        n := n+1;
        i := random(10);
        op := random(4);
        
        case op of
            1: s := "Прибавте ";
            2: s := "Отнимите ";
            3: s := "Умножте на ";
            else s := "Поделите на ";
        end;
        
        writeln(s, i);
        changes[1,n] := op; {запоминаем действия}
        changes[2,n] := i;
    until n = 10;
    
    writeln("Что вышло?");
    readln(res);
    
    for i := n downto 1 do { производим обратные действия }
    begin
        case changes[1,i] of
            1: res := res - changes[2,i];
            2: res := res + changes[2,i];
            3: res := res / changes[2,i];
            else res := res * changes[2,i];
        end;
    end;
        
    writeln("Вы загодали ",res);
END.

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота