Ii. написать программу, которая подсчитывает: 1) периметр квадрата, площадь которого равна а; 2) площадь равностороннего треугольника, периметр которого равен р;
Var n, a, s: real; i: integer; label 1, 2, 3, 4; begin 1: Writeln('1)Периметр квадрата'); Writeln('2)Площадь равностороннего треугольника'); Write('Ваш выбор >>> '); Read(n); Writeln(''); if n = 1 then begin 2: Write('Введите площадь кварата >>> '); Read(s); if s < 0 then begin Writeln('Некорректный ввод'); Writeln(''); goto 2; end; a := Sqrt(s) * 4; Writeln(''); Writeln('Периметр квадрата >>> ', a); goto 4; end else if n = 2 then begin 3: Write('Введите периметр равностороннего треугольника >>> '); Read(a); if a < 0 then begin Writeln('Некорректный ввод'); Writeln(''); goto 3; end; s := (sqrt(3) / 4) * Sqr(a/3); Writeln(''); Writeln('Площадь равностороннего треугольника >>> ', s); goto 4; end else begin Writeln('Некорректный ввод'); Writeln(''); goto 1; end; 4: Writeln(''); Writeln('1)Заного'); Writeln('2)Выйти'); Write('Ваш выбор >>> '); Read(n); Writeln(''); if n = 1 then goto 1 ; else exit; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку