black95
15.10.2021 11:35

Очень класс.Задание по информатике.

Составить программу вычисления значения функции y=√2а+3а2 для любого значения а,введённого с клавиатуры​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Matroskinnn
23.07.2022 20:37

Program Princess;
uses crt;
var
  M:Integer;
begin
  writeln('');
  writeln('*        Вас приветствует ППП         *');
  writeln('*    Программа Проверки Принцесс      *');
  writeln('*                                     *');
  writeln('*      Сейчас узнаем...               *');
  writeln('');
  writeln('1. Постелите постель для девушки');
  writeln('2. Подложите горошину');
  writeln('3. Дождитесь утра...');
  writeln('4. Разбудите девушку');
  writeln('5. Спросите: "Как Вам спалось?" ');
  writeln('6. Введите в систему ответ девушки:');
  writeln('   0 - "Плохо, совсем не сомкнула глаз..." ');
  writeln('   1 - "Отлично выспалась" ');
  readln(M);
  writeln('');
  writeln('*                Итак...              *');
  if m=0 then
  writeln('* Эта девушка - настоящая принцесса!  *')
  else
  writeln('*  Увы! Эта девушка - не принцесса!   *');
  writeln('');
end.

0,0(0 оценок)
Ответ:
Sanek27rus
03.09.2022 16:04

1. Жигули, с единицы номер. 
2. Москвич, с семерки номер. 
3. Иномарка, не с единицы. 
Каждый сказал один факт правду и один - ложь. 
Предположим, что первый верно указал цифру 1. Значит, он обманул относительно жигулей. Раз номер с единицы начинается, то другие двое обманули относительно номера, а значит, верно указали марку машины. Но они не могли оба верно указать марку, ведь один сказал - "Москвич", а второй - "иномарка". Значит первое предположение, что номер начинается с единицы - привело нас в тупик. Раз номер не с единички, то первый обманул про номер, значит правду сказал про марку - это "Жигули". 
Раз марка жигули, то второй обманул про Москвич, а значит верно сказал про номер с семерки. Третий значит, обманул про иномарку, но верно сказал, что номер не с единицы начинается. 
Итого - это были "Жигули" и номер начинается с семерки.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота