Алинулька11
22.04.2020 03:08

Задача для Python по теме множества
Напишите программу, которая находит все различные цифры в символьной строке.
Входные данные
На вход программе подаётся символьная строка.
ыходные данные
Программа должна вывести в одной строке все различные цифры, которые встречаются в исходной строке, в порядке возрастания. Если в строке нет цифр, нужно вывести слово 'NO'.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Bezzybka
12.10.2020 01:07

string = input().split()

number_list = []

for elem in string:

   if elem.isdigit() == True:

       number_list.append(elem)

number_list.sort()

if len(number_list) == 0:

   print('NO')

else:

   print(number_list)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота