kolodenkoa444
12.06.2020 05:58

Напишите программу в двухмерном массиве 6*3 для каждой нечетной строки определить произведение положительных элементов

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Mini03
05.10.2020 05:05
Var
arr:array[1..6,1..3] of integer;
i,j:integer;
p:longint;
begin
randomize;
p:=1;
for i:=1 to 6 do
begin
for j:=1 to 3 do
begin
arr[i,j]:=random(10);
write(arr[i,j]:5);
end;
writeln;
end;
for i:=1 to 6 do
begin
if i mod 2<>0 then
begin
for j:=1 to 3 do
if arr[i,j]>0 then p:=p*arr[i,j];
end;

end;
writeln('Произведение положительных элементов нечетных строк: ', p);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота