Derbershto397
04.11.2021 06:49

Написать программу которая запросит длинны трёх сторон треугольника. проверить возможность его сущ. и в предположенном результате найдёт и выведет на экран площадь один кто !

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Танюша9102
05.10.2020 04:05
Var  
a,b,c{длины сторон}, S{площадь тр.}, p{полупериметр}:double;
begin
writeln('Введите стороны треугольника:');
readln(a,b,c);
     if (a>=b+c) or (b>=a+c) or (c>=a+b) then     
     writeln ('Такого треугольника не существует')     
     else begin   
     p:=(a+b+c)/2;     
     S:=sqrt(p*(p-a)*(p-b)*(p-c)); {вычисляем S тр. по формуле Герона}     
     writeln ('Такой треугольник существует, его S = ', S, 'ед.');     
     end;     
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота