ruslankz02
23.05.2020 07:50

Составьте программу которая заполняет массив b случайными целыми числами в диапазоне от 1 до 10 и находиь произведение элементов с нечетными значениями и количество элементов с четными значениями

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
okru24057p00ymy
04.10.2020 19:55
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(8,1,10); a.Println;
  Writeln('Произведение нечетных элементов ',
    a.Where(x->x.IsOdd).Aggregate(1,(x,y)->x*y));
  Writeln('Количество четных элементов ',
    a.Where(x->x.IsEven).Count)
end.

Пример
9 10 10 5 8 3 5 2
Произведение нечетных элементов 675
Количество четных элементов 4
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота