888oksana888
31.05.2020 19:17

Составьте программу алгоритма определения высоты Н, медианы М, площади треугольника S, заданного координатами своих вершин XI, Y l , Х2, Y2, ХЗ, Y3.
Я НИЧЕГО НЕ ЗНАЮ
​


Составьте программу алгоритма определения высоты Н, медианы М, площади треугольника S, заданного коо

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kiiss
21.12.2022 04:57

Объяснение:

1. Гиперссылка — часть гипертекстового документа, ссылающаяся на элемент в этом документе или на другой объект, расположенный на локальном диске или в компьютерной сети, либо на элементы этого объекта.

2. Внутренние ссылки – это ссылки на объекты в пределах одного документа.

Внешние или удаленные ссылки – это ссылки на другие Web-серверы.

Относительные или локальные ссылки – это ссылки на другие Web-страницы или службы Internet, расположенные на одном сервере со страницей, содержащей ссылки.

3. 1 Выделите текст или рисунок, который должен представлять гиперссылку.

1. Нажмите CTRL+K. Можно также щелкнуть текст или рисунок правой кнопкой мыши и в shortcut-меню щелкнуть ссылку.

2. В окне Вставка гиперссылки введите или вставьте ссылку в поле Адрес.

4. Часть текста с добавленной ссылкой по умолчанию выделяется синим цветом, как в предыдущем предложении. При наведении курсора мыши на текст со ссылкой он или меняет цвет или выделяется подчеркиванием.

0,0(0 оценок)
Ответ:
okfuh
09.11.2020 10:17

Вот такая программа позволяет инвертировать нечётные биты во введённом 16-ти разрядном числе (тип word).

Если что, счёт битов я брал начиная с нуля. Поэтому, младший бит (нулевой) считается чётным. Если вдруг у вас там принято считать биты начиная с единицы, то младший будет нечётным, и тогда в строке где b := 2;  надо поставить единицу вместо двух.

Также, я сделал отображение всех 16 разрядов введённого числа, и числа которое получилось после инверсии битов (то есть, число выводится в двоичном виде, начиная со старших разрядов). Это сделано для удобства проверки работы программы.

После проверки лучше удалить эти две строки (они выделены жирным шрифтом), ведь в задании не сказано выводить числа в двоичном виде.

var

a, b, n: word;

begin

write('Введите целое неотрицательное число: a= ');

readln(a);

b:=32768;for n:=15 downto 0 do begin write((a mod(b*2))div b);b:=b div 2;end;writeln();

b := 2;

for n := 0 to 7 do

begin

if (a mod (b * 2)) div b = 0

then a := a + b

else a := a - b;

b := b * 4;

end;

b:=32768;for n:=15 downto 0 do begin write((a mod(b*2))div b);b:=b div 2;end;writeln();

writeln('После инверсии нечётных битов: a= ', a);

end.


Дано целое неотрицательное число. Получить число, инвертируя его нечетные биты. Решить в паскале
Дано целое неотрицательное число. Получить число, инвертируя его нечетные биты. Решить в паскале
Дано целое неотрицательное число. Получить число, инвертируя его нечетные биты. Решить в паскале
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота