J980
09.05.2021 04:35

Надо написать на паскале в заданном массиве определите количество элементов,которые меньше заданного с клавиатуры числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
гегпнгеггне
14.08.2020 09:26
Const
  n=10;
var
  i,m,k:integer;
  a:array[1..n] of integer;
begin
  Randomize;
  Write('Исходный массив: ');
  for i:=1 to n do begin a[i]:=Random(90)+10; Write(a[i],' ') end;
  Writeln;
  Writeln('Введите целое число: '); Read(m);
  k:=0;
  for i:=1 to n do
    if a[i]<m then Inc(k);
  Writeln('Количество чисел, меньших ',m,' равно ',k)
end.

Тестовое решение:
Исходный массив: 42 89 49 25 96 87 94 93 41 28
Введите целое число:
50
Количество чисел, меньших 50 равно 5
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота