pelmen123456789
02.08.2020 07:43

C++
Написать программу которая заполняет рандомно массив и считает сумму этих чисел​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Aleksandra2320323
06.04.2021 13:24

#include <iostream>

#include <cstdlib>

#include <ctime>

typedef int datatype;

void init_array(datatype* arr, int SIZE)

{

   for (int i = 0; i < SIZE; ++i)

       arr[i] = rand() % 100;

}

void show_array(datatype* arr, int SIZE)

{

   std::cout << "array: ";

   for (int i = 0; i < SIZE; ++i)

       std::cout << arr[i] << " ";

   std::cout << "\n";

}

datatype find_sum(datatype* arr, int SIZE)

{

   datatype sum = 0;

   for (int i = 0; i < SIZE; ++i)

       sum += arr[i];

   return sum;

}

int main()

{

   std::cout << "enter a size of the array: ";

   int SIZE;

   std::cin >> SIZE;

   datatype *arr = new datatype[SIZE];

   srand(time(NULL));

   init_array(arr, SIZE);

   show_array(arr, SIZE);

   std::cout << "sum of elements: " << find_sum(arr, SIZE) << "\n";

   delete[] arr;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота