Аартём1
23.08.2022 06:13

Напишите программу, которая производит обмен згачений переменных x и y, если x больше y. пример входных пример выходных данных данных x> > 5 x=6 y> > 6. y=5 x> > 6 x=5 y> > 5. y=6

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
диана2340
31.07.2020 18:48
Решение №1
var x,y:integer;
begin
  readln(x,y);
  if x> y then begin
     x:=x+y;
     y:=x-y;
     x:=x-y;
     writeln(x,' ',y);
end.

Тестовое решение:
8 5
5 8

Решение №2
На PascalABC.Net можно сделать проще:

var x,y:integer;
begin
 readln(x,y);
 if x>y then begin  swap(x,y); println(x,y); end;
end.
 
 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота