nikakoheleva14
13.11.2022 12:10

Исполнитель умеет выполнять два действия: «+1», «*2». Составьте программу получения из числа 1 числа 100. Pascal

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
лейла20032
05.06.2020 02:53
Суждение:
1. Все сосны являются деревьями.
2.Ни один кит - не рыба.
3.Все караси являются рыбами.
4. Все розы - это цветы.
5. Все мухи - это птицы.

Умозаключения:
1. Ты задал вопрос, вопрос задают когда не знают. Умозаключение: ты не знаешь.
2. Все прямоугольники-параллелограммы. Квадрат - это прямоугольник. Умозаключение: квадрат - это параллелограмм.
3. Все люди смертны. Сократ - человек. Умозаключение: Сократ смертен.
4. Звезды взрываются. Солнце - звезда. Умозаключение: Солнце взорвется.
5. У треугольника все углы равны. Умозаключение: треугольник равноугольный
0,0(0 оценок)
Ответ:
2508sanya
06.10.2021 20:12

Задание №1:
int(-5,89)= -5
int(0,53)=0
round(-5,8)=-6
round(5,2)=5
frac(-17,4)=0,4
frac(0,32)=0,32
trunc(-17,4)=-17
trunc(15,2)=15
45 div 4=11
15 mod 8=7
(489 div 10) mod 10=8

Задача №2:

а=1, в=2;     a=2

а=3, в=3;    a=0

а=4, в=2;    a=2

а=-3, в=5    a=-15

Задача №3:

var m,s:integer;
begin
readln(m);
readln(s);
if s>m then writeln('Саша старше Маши')
        else if m>s then writeln('Маша старше Саши ')
              else writeln('Саша и Маша ровесники');
end.

Задача №4:

var a:real;
begin
write('Введите число: ');
readln(a);
if a>0 then a:=a/7
        else a:=a*a;
writeln(a);
end.

Задача №5:

var a,b:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
if a>b then writeln('Наибольшее число: ',a)
        else writeln('Наибольшее число: ',b);
end.

Задача №6:

var a,b,c,p:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
if a>b then if a>c then p:=a
                    else p:=c
       else if b>c then p:=b
                    else p:=c;
writeln('Наибольшее число: ',p);
end.

Задача №7:

var a,b,c,d,p:real;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
write('Введите четвертое число: ');
readln(d);
if a>b then if a>c then p:=a
                    else p:=c
       else if b>c then p:=b
                    else p:=c;
if p<d then p:=d;
writeln('Наибольшее число: ',p);
end.

Задача №8:

var a:real;
begin
a:=0;
while a<7.9 do
begin
  write('Введите скорость ракеты: ');
  readln(a);
  if (a>=7.9) and (a<11.2) then writeln('Ракета станет спутником Земли')
    else if (a>=11.2) and (a<16.6) then writeln('Ракета станет спутником Cолнца')
          else if a>=16.6 then writeln('Ракета покинет Cолнечную систему')
                          else writeln('Требуется повторный ввод скорости');
end;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота