em130STM
15.04.2023 12:16

1. напишите программу, которая выводит значение порядкового номера этого значения. 2. напишите программу, которая подсчитывает количество элементов в массиве,равных 5. ,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dianakazaryan1
03.10.2020 11:48
1)
var a:array [1..100] of integer;
i,n,k:integer;
begin
readln(n); //количество элементов массива
for i:=1 to n do
read(a[i]); //ввод массива через пробел с клавиатуры
writeln;
readln(k); //ввод значения, номер которого будем искать
for i:=1 to n do
if a[i]=k then writeln(i) //поиск номера введенного элемента
end.
2)
var a:array [1..100] of integer;
i,n,s:integer;
begin
s:=0;
readln(n); //количество элементов массива
for i:=1 to n do
read(a[i]); //ввод массива через пробел с клавиатуры
writeln;
for i:=1 to n do
if a[i]=5 then s:=s+1; //подсчёт кол-ва элементов равнх 5
writeln(s)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота