diana1156
25.07.2020 01:17

C++. напишите программу, которая вводит номер месяца и выводит название времени года на языке. при вводе неверного номера месяца должно быть выведено слово 'no'.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
diiann
06.10.2020 22:10
#include <iostream>
using namespace std;

int main()
{
    cout << "Enter month num: " << endl;
    unsigned month = 0;
    cin >> month;
    if (month <= 12 && month >= 1) {
    switch (month / 3) {
    case 1:
        cout << "Spring" << endl;
        break;
    case 2:
        cout << "Summer" << endl;
        break;
    case 3:
        cout << "Autumn" << endl;
        break;
    default:
        cout << "Winter" << endl;
        break;
    }
    } else {
     cout << "NO" << endl;   
    }
return 0;
}
0,0(0 оценок)
Ответ:
vladwf111
06.10.2020 22:10
#include <iostream>

using namespace std;

int main(){
int x;
cin >> x;
if(x <= 0)
   cout << "NO"
else if(x < 3)
   cout << "Winter";
else if(x > 2 and x < 6)
   cout << "Spring";
else if(x > 5 and x < 9)
   cout << "Summer";
else if(x > 8 and x < 12)
   cout << "Autumn";
else
   cout << "NO;
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота