Kornella
18.10.2021 13:50

Питон 17 .
в левом верхнем углу прямоугольной таблицы размером n×m находится черепашка. в каждой клетке таблицы записано некоторое число. черепашка может перемещаться вправо или вниз, при этом маршрут черепашки заканчивается в правом нижнем углу таблицы.

подсчитаем сумму чисел, записанных в клетках, через которую проползла черепашка (включая начальную и конечную клетку). найдите наибольшее возможное значение этой суммы и маршрут, на котором достигается эта сумма.

входные данные
в первой строке входных данных записаны два натуральных числа n и m, не превосходящих 100 — размеры таблицы. далее идет n строк, каждая из которых содержит m чисел, разделенных пробелами — описание таблицы. все числа в клетках таблицы целые и могут принимать значения от 0 до 100.

выходные данные
первая строка выходных данных содержит максимальную возможную сумму, вторая – маршрут, на котором достигается эта сумма. маршрут выводится в виде последовательности, которая должна содержать n-1 букву d, означающую передвижение вниз и m-1 букву r, означающую передвижение направо. если таких последовательностей несколько, необходимо вывести ровно одну (любую) из них.

примеры
входные данные
5 5
9 9 9 9 9
3 0 0 0 0
9 9 9 9 9
6 6 6 6 8
9 9 9 9 9
выходные данные
74
d d r r r r d d

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dem0N1
04.07.2020 16:11
Для начала посчитаем, сколько бит информации было передано:
2 минуты и 45 секунд = 165 секунд
165 с * 128000 бит/с = 21120000 бит

Теперь вспомним, что такое частота дискретизация и уровни квантования. Дело в том, что аудио сигнал - это такая прикольная сложная синусоида. Чтобы записать сигнал в цифровом виде, каждую секунду сигнала как бы делят на промежутки (количество этих промежутков в секунде и есть частота дискретизации). Для каждого из этих промежутков записывается что-то вроде среднего значения высоты. Количество возможных значений - количество уровней квантования.
Но это так - если говорить очень упрощённо. Подробнее прочитайте в своём учебнике информатики.

Итак - у нас 256 уровней квантования. Значит каждое из значений можно записать 8 битами.
И на секунду у нас приходится 22000 таких записей.
То есть каждая секунда записи у нас кодируется 22000 * 8 = 176000 битами.

21120000 / 176000 = 120 секунд.
0,0(0 оценок)
Ответ:
kristinalyapina1
03.08.2020 13:16
#include <iostream>
#include <list>

using namespace std;

int main() {
    list<int>mylist;
    //Делаем со списком, что хотим
    mylist.push_back(1);
    mylist.push_back(2);
    mylist.push_back(3);
    mylist.push_back(-4);
    mylist.push_back(5);
    for (auto i : mylist) {
        cout << i << " ";
    }
    cout << "\n";
    //Удаляем последний отрицательный элемент
    auto it = mylist.end();
    while (*it > 0) {
        if (it == mylist.begin()) {
            cout << "Not found.\n";
            return 0;
        }
        it--;
    }
    //Делаем со списком, что хотим
    mylist.erase(it);
    for (auto i : mylist){
        cout << i << " ";
    }
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота