reegiinaaa
27.11.2020 00:29

Как написать программу на пайтоне для примера

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Елька165
29.07.2020 19:17
Как-то так var a,b,c,h,p,s:real; var ch:char; var f:boolean;
begin
repeat
write('Êàê ñ÷èòàåì ïëîùàäü? 1-Ïî Ãåðîíó, 2-÷åðåç ïîëîâèíó ïðîèçâåäåíèÿ îñíîâàíèÿ íà âûñîòó: ');
readln(ch);
if ch='1' then begin
write('a='); read(a); write('b='); read(b); write('c='); read(c);
p:=(a+b+c)/2; s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('Ïëîùàäü ðàâíà ',s); f:=true;
end
else if ch='2' then begin
write('a='); read(a); write('h='); read(h);
writeln('Ïëîùàäü ðàâíà ',0.5*h*a);
f:=true;
end
else begin cls; writeln('Îòâåò ôèãîâûé! Åùå ðàçîê: 1-Ïî Ãåðîíó, 2-÷åðåç ïîëîâèíó ïðîèçâåäåíèÿ îñíîâàíèÿ íà âûñîòó: '); end;
until f;
end.
0,0(0 оценок)
Ответ:
julyafluke
29.07.2020 19:17
Как-то так var a,b,c,h,p,s:real; var ch:char; var f:boolean;
begin
repeat
write('Êàê ñ÷èòàåì ïëîùàäü? 1-Ïî Ãåðîíó, 2-÷åðåç ïîëîâèíó ïðîèçâåäåíèÿ îñíîâàíèÿ íà âûñîòó: ');
readln(ch);
if ch='1' then begin
write('a='); read(a); write('b='); read(b); write('c='); read(c);
p:=(a+b+c)/2; s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('Ïëîùàäü ðàâíà ',s); f:=true;
end
else if ch='2' then begin
write('a='); read(a); write('h='); read(h);
writeln('Ïëîùàäü ðàâíà ',0.5*h*a);
f:=true;
end
else begin cls; writeln('Îòâåò ôèãîâûé! Åùå ðàçîê: 1-Ïî Ãåðîíó, 2-÷åðåç ïîëîâèíó ïðîèçâåäåíèÿ îñíîâàíèÿ íà âûñîòó: '); end;
until f;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота