Kefir4ek
28.05.2022 17:48

Нужна ваша ! написать программу на паскале: сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.( в ответе достаточно рабочего кода)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
steel09090
16.09.2020 22:14
Const n=5; m=6;
var a: array [1..n,1..m] of integer;
    sum,min,i,j:integer;
begin
Randomize;
writeln('---A:---');
for i:=1 to n do begin
  for j:=1 to m do begin
    a[i,j]:=Random(20)-10;
    write(a[i,j]:6);
  end;
  writeln;
end;
writeln('Среднее арифм. столбцов:');
min:=100000;
for j:=1 to m do begin
 sum:=0;
 for i:=1 to n do sum:=sum+a[i,j];
 write(sum/n:6:2);
 if sum<min then min:=sum;
end;
writeln;
writeln('Min=',min/n:6:2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота