666223
09.09.2022 06:44

Составить программу ,которая формирует массив ,содержащий 12 случайных целых чисел ,принадлежащий промежутку [-7; 10],и подсчитывает кол-во всех отрицательный чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
сафие89
13.07.2020 07:24
#include <iostream>
#include <stdlib.h>      
#include <time.h>       

int main()
{
  srand(time(NULL));

  int a[12];
  int s = 0;
  for (int i = 0; i < 12; ++i){
    a[i] = rand() % 18 - 7;
    if (a[i] < 0) s++;
  }
  std::cout << s;
   return 0;
}
0,0(0 оценок)
Ответ:
мамкакактус
13.07.2020 07:24
Паскаль:
var i,t:integer;
    a:array[1..12] of integer;
begin  randomize;
  for i := 1 to 12 do begin
    a[i] := round( random(17)-7 );
    write(a[i]:3);
  end;
  t := 0;
  for i := 1 to 12 do
    if a[i] < 0 then
      inc(t);
  writeln;
  writeln(t);
  readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота