tsvirko7891
06.02.2020 11:35

Написать программу в турбо паскале. : дан текстовый файл f. исключить гласные буквы из строк и поместить результат в файл q.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
arisazenina783
01.10.2020 22:53
var
  f, q: Text;
  i: integer;
  s: string;

begin
  Assign(f, 'in.txt');
  Reset(f);
  Assign(q, 'out.txt');
  rewrite(q);
  while not EOF(f) do
  begin
    readln(f, s);
    i := 1;
    while (i <= length(s)) do
    begin
      if (upcase(s[i]) in ['А', 'Е', 'Ё', 'И', 'О', 'У', 'Ы', 'Ю', 'Я']) then
        delete(s, i, 1);
      inc(i);
    end;
    writeln(q, s);
  end;
  close(f); close(q);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота