Хантенир11
26.04.2020 11:59

Составить программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превышает 100 (каждое число с новой строки), и если среди них есть неотрицательное число, то выводит это число или выводит сумму всех отрицательных введенных чисел в остальных случаях.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
edigarian2016
25.05.2020 14:22

Program n1;
Uses CRT;
Var a,b,c: integer;
begin
ClrScr;
Writeln('Vvedite chisla');
Readln(a,b,c);
If(a<0)and(b<0)and(c<0) then writeln('Summa = ',a+b+c)
else
if (a>0) then writeln('polozhitelnoe chislo ',a) else
if (b>0) then writeln('polozhitelnoe chislo ',b) else
if (c>0) then writeln('polozhitelnoe chislo ',c);
readln
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота