Маря04
25.09.2020 17:20

С1. составить алгоритм и написать программу на вычисление скорости или пути, при условии, если t> 1часа, тогда вычисляем скорость, иначе путь. каждую строку программы, прокомментировать. входные данные t=2 часа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
777Leha777
07.07.2020 07:54
Алгоритм:
Начало
Ввод t
Если t>1 часа, то
начать выполнение операторов
ввод S;
V=S/t;
вывод V
закончить выполнение операторов
иначе
начать выполнение операторов
ввод V;
S=Vt;
вывод S;
закончить выполнение операторов

Var S,V,t:integer;
begin
read(t);
if t>1 then
begin
read(s);
v:=s/t;
writeln('Скорость=',v);
end
else
begin
read(v);
s:=v*t;
writeln('Расстояние=',s);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота