Написать программу чтоб работала в pascal запрашивает с клавиатуры три произвольных числа и выводит на экран сообщение о том, сколь-ко из них отрицательных, положительных и нулевых.
PascalABC var x,y,z:real; k,m,n:integer; begin k:=0; m:=0; n:=0; writeln('Введите первое число'); readln(x); writeln('Введите второе число'); readln(y); writeln('Введите третье число'); readln(z); if x>0 then k:=k+1 else if x=0 then m:=m+1 else n:=n+1; if y>0 then k:=k+1 else if y=0 then m:=m+1 else n:=n+1; if z>0 then k:=k+1 else if z=0 then m:=m+1 else n:=n+1; writeln('Количеcтво положительных чисел : ',k); writeln('Количеcтво нулевых чисел : ',m); writeln('Количеcтво отрицательных чисел : ',n); end.
Program pr; var a,b,nul,otr,pol,c:integer; begin write('A='); readln(a); write('B='); readln(b); write('C='); readln(c); if a>0 then pol:=pol+1 else if a=0 then nul:=nul+1 else otr:=otr+1; if b>0 then pol:=pol+1 else if b=0 then nul:=nul+1 else otr:=otr+1; if c>0 then pol:=pol+1 else if c=0 then nul:=nul+1 else otr:=otr+1; writeln('Положительных: ',pol); writeln('Отрицательных: ',otr); writeln('Нулевых: ',nul); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку